ElectroEngineer

[1.77.1.34] Не работает многоканальный звук 5.1

Доброго дня.

Суть проблемы в том, что при выбранной настройке звука 5.1 в лончере, никакой разницы по сравнению со стерео не заметно. Проверяю следующим образом: включаю поочередно разные каналы и если звук не отличается, то значит многоканальность не работает. Также пробовал запускать игру под wine и там 5.1 звук работал при прочих равных.

Сам по себе 5.1 у меня везде работает, где есть поддержка. Т.е. и в фильмах с соответствующими дорожками я могу четко слышать разделение по каналам и во многих играх, например в ut2004 или serious sam 3.

Проверял также на чистой alsa с полностью отключенным pulseaudio, и к удивлению звук в игре превращался в кашу. Т.е. как будто звук со всех 6 каналов смешивается вместе и проигрывается очень быстро.

конфиг alsa следующий ~/.asoundrc

Скрытый текст

pcm.!default {
type plug
slave.pcm "surround51"
slave.channels 6
route_policy duplicate
}

Еще замечу, что этот конфиг влияет только на приложения которые используют для вывода alsa. С pulseaudio он никак не пересекается, там создаются отдельные устройства в соответствии с настроками самой пульсы, которые в данном случае состоят из одной строки default-sample-channels = 6 в /etc/pulse/daemon.conf

лог при запуске с pulseaudio: 2018_03_23_15_29_47__20748.clog

лог при запуске с alsa: 2018_03_23_16_39_52__27964.clog

Если надо, я конечно могу попробовать записать видео со звуком для примера, но не знаю как записывать чтобы был многоканальный звук и не порежет ли многоканальность тот же ютуб.

config.blk

Скрытый текст

forcedLauncher:i=0
renderer2:t="auto"
doShowDriversOutdated:b=yes
language:t="Russian"
use_release_candidate:b=no
releaseChannel:t=""
clientType:t="32bit"
hdClient:b=no
graphicsQuality:t="custom"
use_gamepad_cursor_control:b=no

yunetwork{
  curCircuit:t="production"
  enableWebStatus:b=no
  webStatusPort:i=23456
}

video{
  mode:t="fullscreen"
  resolution:t="1920 x 1200"
  instancing:t="auto"
  compatibilityMode:b=no
  postfx_antialiasing:t="fxaa"
  disableFlipEx:b=no
  oculus:b=no
  alpha_to_coverage:b=yes
  driver:t="auto"
  windowed:b=no
  vsync:b=no
  adaptive_vsync:b=no
  fonts:t="small"
}

graphics{
  advancedShore:b=yes
  tireTracksQuality:i=2
  enemiesQuality:t="low"
  enableSuspensionAnimation:b=yes
  skyQuality:i=1
  lenseFlares:b=yes
  waterReflectionTexDiv:i=6
  shadowQuality:t="medium"
  cloudsQuality:i=1
  texquality:t="high"
  dirtSubDiv:i=1
  hqHangarWeather:b=no
  landquality:i=2
  waterRefractionEnabledFor:i=1
  panoramaResolution:i=2048
  clipmapScale:r=1
  fxDensityMul:r=0.8
  backgroundScale:r=1
  rendinstDistMul:r=1
  grassRadiusMul:r=0.75
  anisotropy:i=4
  lastClipSize:i=8192
  foliageReprojection:b=no
  physicsQuality:i=3
  foamQuality:t="high"
  contactShadowsQuality:i=0
  displacementQuality:i=1
  ssaa:r=1
}

render{
  selfReflection:b=yes
  fxReflection:b=yes
  grass:b=yes
  motionBlur:b=yes
  waterReflection:b=yes
  rendinstGlobalShadows:b=yes
  shadows:b=yes
  softFx:b=yes
  ssaoQuality:i=1
  haze:b=yes
  wake:b=yes
  ssrQuality:i=0
  staticShadowsOnEffects:b=yes
}

launcher{
  carouselImagesListUrlOverride:t="127.0.0.1:23456/web/carousel-images.csv"
  startup_with_windows:b=no
  hide_to_tray_option:b=yes
  enableCarousel:b=no
  carouselHtmlUrlOverride:t="127.0.0.1:23456/web/carousel.html"
  overrideCarouselUrls:b=yes
}

download{
  dnl_speed_rate:i=1000
  upl_speed_rate:i=1000
  tracker_exchange:b=yes
  upl_limit:b=no
  peer_exchange:b=yes
  UTP:b=yes
  seeding_on:b=yes
  DHT:b=yes
  dnl_limit:b=no
}

directx{
  d3d9ex:b=yes
  maxaa:i=0
}

oculus{
  maxSeparation:r=0.0005
  predictionEnabled:b=no
  k1:r=0.5
  fovMul:r=1.2
  magnetometerEnabled:b=no
  edgeScale:r=0.95
  zeroParallaxDist:r=3
  k2:r=0.666
}

sound{
  speakerMode:t="5.1"
  fmod_sound_enable:b=yes
}

debug{
  screenshotAsJpeg:b=yes
  512mboughttobeenoughforanybody:b=yes
}

 

 

inxi -F

Скрытый текст

System:    Host: desktop Kernel: 4.15.11-1-ARCH x86_64 bits: 64 Desktop: KDE Plasma 5.12.3 Distro: Arch Linux
Machine:   Device: desktop Mobo: ASRock model: Z97 Anniversary serial: N/A
           UEFI [Legacy]: American Megatrends v: P1.90 date: 10/13/2015
CPU:       Quad core Intel Core i5-5675C (-MCP-) cache: 4096 KB
           clock speeds: max: 3600 MHz 1: 2916 MHz 2: 2305 MHz 3: 2631 MHz 4: 2655 MHz
Graphics:  Card: Intel Iris Pro Graphics 6200
           Display Server: x11 (X.Org 1.19.6 ) driver: intel Resolution: 1920x1200@59.95hz
           OpenGL: renderer: Mesa DRI Intel Iris Pro 6200 (Broadwell GT3e) version: 4.5 Mesa 17.3.6
Audio:     Card Creative Labs EMU10k2/CA0100/CA0102/CA10200 [Sound Blaster Audigy Series] driver: snd_emu10k1
           Sound: Advanced Linux Sound Architecture v: k4.15.11-1-ARCH
Network:   Card: Intel Ethernet Connection (2) I218-V driver: e1000e
           IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: d0:50:99:99:25:23
Drives:    HDD Total Size: 2448.5GB (26.8% used)
           ID-1: /dev/sdb model: TOSHIBA_MQ01ABF0 size: 320.1GB
           ID-2: /dev/sda model: OCZ size: 128.0GB
           ID-3: /dev/sdc model: ST2000DM006 size: 2000.4GB
Partition: ID-1: / size: 118G used: 84G (73%) fs: ext4 dev: /dev/sda1
Sensors:   System Temperatures: cpu: 31.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 236 Uptime: 2:30 Memory: 2849.6/15490.2MB Client: Shell (bash) inxi: 2.3.56

 

medal medal

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу